Vim은 매우 강력한 텍스트 편집기이며 거의 모든 최신 컴퓨팅 플랫폼에서 사용할 수 있습니다. 그것은 거의 리눅스 배포판의 기본 설치에 번들로 제공, 비록 우분투 는 덜 강력 하 게 또는 유용 하 게 강조 하는 구문 강조 와 같은 기능을 부족 Vim의 최소 버전과 함께 제공. Vim우분투에서 기본적으로 설치 되지 않는 이유까지, 우분투는 비 기술 적인 군중으로 기어드 때문에 그것을 말할 것 이다: a) 이제까지 명령줄 텍스트 편집기를 사용 하지 않습니다.; 및 b:) 그들이 그것을 원하는 경우 충분히 쉽게 설치하는 방법을 알아낼 것입니다. 소프트웨어 업데이트, 우분투 소프트웨어 센터, 시냅틱 패키지 관리자 또는 설치 또는 업데이트중이면 다른 터미널 탭이 열려 있는지 확인합니다. 열려 있을 수 있는 이 모든 것을 닫은 다음 명령을 다시 실행합니다. 이번에는 작동합니다. 어떻게이 문제를 해결 하 고 왜 vim 우분투 리눅스에 기본 텍스트 편집기? 어떻게 우분투 리눅스에서 본격적인 vim 텍스트 편집기를 설치할 수 있습니까? Vim (Vi IMproved)은 Vi와 호환되는 위쪽 텍스트 편집기입니다. 모든 종류의 일반 텍스트를 편집하는 데 사용할 수 있습니다. 쉘, 파이썬, 펄, c /c ++ 등으로 작성된 구성 파일 및 프로그램을 편집하는 데 특히 유용합니다. VIM은 기본적으로 우분투에 설치되어 있지 않지만 VI는 설치되지 않습니다.

나는 당신의 명령을 사용 후 VMware 워크 스테이션우분투 14.10을 운영했다, 그것은 단지 일부 인덱스 파일이 다운로드하는 데 실패 한 것을 보여줍니다. 대신 사용 되 었던 이전 무시 되었습니다. 터미널에서 apt를 통해 우분투에 Vim의 전체 버전을 설치할 수 있습니다. 당신은 당신의 우분투 소프트웨어의 버전을 명시 할 수 있습니까? 시도 : 당신은 지금 vim 텍스트 편집기를 사용할 수 있습니다 : $ vi file.c $ vim file.c $ sudo vim / etc / sysctl.conf 샘플 출력 : Fig.01 : 우분투 얌에 행동에 Vim 데비안이나 우분투의 일부가 아닙니다. 빨간 모자의 일부입니다. 하지만, 그것은 우분투에서 작동 하 고 그것은 기본적으로 처럼 설치 되어 apt-get 내부 컨테이너 (도커에, VM에서), 기본적으로 이들은 설치 되지 않습니다. 심지어 apt-get, wget 작동하지 않습니다. 내 VM은 우분투에서 실행 17.10. 나를 위해 얌 패키지 마나거 일했다. 기본적으로 우분투와 함께 제공 되지 않는 몇 가지 다른 것 들 개발 도구 (gcc, 확인, 등) 또는 ssh 서버. 대부분의 리눅스 배포판 이러한 사전 설치 와 함께 제공, 하지만 난 이것 또한 때문에 우분투의 대상 관객으로 인식 하는 정식 의 결석 가정. 그럼에도 불구 하 고, 우분투는 여전히 기본 apt 저장소에 Vim에 더 많은 기능이 풍부한 버전을 제공 합니다.

Vim은 텍스트 편집기 및 Vi 편집기의 개선 된 버전입니다. 그것은 CLI (명령 줄 인터페이스) 및 GUI (그래픽 사용자 인터페이스) 응용 프로그램으로 사용하도록 설계되었습니다. 나는 또한 vim (많은 플러그인, 색 구성표 등)에 대한이 궁극적 인 vimrc를 사용합니다 : https://github.com/amix/vimrc 여기 Vim 5.7의 다중 바이트 버전입니다 (일본어, 한국어 및 중국어는 물론 유니코드의 경우): HTTP://WWW-IMAI.IS.S.U-TOKYO.AC.JP/~ASAI/MACVIM-E.HTML MS-Windows 응용 프로그램으로 실행되는 세 가지 버전이 있습니다. 이러한 메뉴, 스크롤 막대 및 도구 모음을 제공합니다. . 백그라운드에서 실행중인 프로그램을 확인하는 방법? 모든 새 버전에 대해 이 페이지를 업데이트하지 않으려면 다른 응용 프로그램이 실행되지 않고 디렉터리에 대한 링크가 있습니다. 여기에서 다운로드할 파일을 선택합니다. 파일 이름에서 ##은 버전 번호를 의미합니다. 예를 들어 버전 8.2가 있는 vim##src.zip은 vim82src.zip이고 버전 8.2의 vim-8.2-src.tar.gz는 vim-8.2-src.tar.gz입니다.

최신 버전에 빠르게 액세스할 수 있도록 링크가 제공됩니다. 이 링크는 최신 버전(현재 8.2)을 가리키며, 이러한 캐싱을 피하면 이전 버전을 얻을 수 있습니다. 당신이 서명 된 버전을 원하는 경우 vim-win32-installer에서 빌드를 얻을 수 있습니다 그것은 많은 인터페이스를 지원합니다, 이러한 펄 등, Tcl, 루아, 파이썬과 루비. 64 비트 MS-Windows에서만 실행되고 더 많은 메모리를 사용하지만 64 비트 플러그인과 호환되는 64 비트 버전도 있습니다.